HOME情報セキュリティ情報セキュリティ対策脆弱性対策脆弱性関連情報取扱い:脆弱性関連情報の調査結果

本文を印刷する

情報セキュリティ

脆弱性関連情報取扱い:脆弱性関連情報の調査結果

独立行政法人 情報処理推進機構
セキュリティセンター

本資料は、JVNで公表した「JVN#29273468:『QRcode Perl CGI & PHP scripts』におけるサービス運用妨害の脆弱性」について解説するものです。

概要:

「QRcode Perl CGI & PHP scripts」 は QR コード画像を作成するための CGI プログラムです。

「QRcode Perl CGI & PHP scripts」 0.50f 以前のバージョンには、特定のリクエストにより、CGI プログラムがサーバ上のリソースを過剰に消費してしまう問題があります。

最新情報は、JVN#29273468を参照してください。

QRcode Perl CGI & PHP scripts におけるサービス運用妨害の脆弱性

影響:

CGI プログラムがサーバ上のリソースを過剰に消費することで、サーバの処理負荷が急激に上昇し、処理速度が極端に低下する可能性があります。結果として、一見 CGI の応答が停止したような状態になります。また、サーバ上で動作している他のアプリケーションでも処理速度が極端に低下する可能性があります。

本脆弱性の深刻度:

(1)評価結果

本脆弱性の深刻度 □ I(注意) ■ II(警告) □ III(危険)
本脆弱性のCVSS基本値   5.0  

(2)CVSS基本値の評価内容

AV:攻撃元区分 □ ローカル □ 隣接 ■ ネットワーク
AC:攻撃条件の複雑さ □ 高 □ 中 ■ 低
Au:攻撃前の認証要否 □ 複数 □ 単一 ■ 不要
C:機密性への影響
 (情報漏えいの可能性)
■ なし □ 部分的 □ 全面的
I:完全性への影響
 (情報改ざんの可能性)
■ なし □ 部分的 □ 全面的
A:可用性への影響
 (業務停止の可能性)
□ なし ■ 部分的 □ 全面的

注)■:選択した評価結果
AV:AccessVector, AC:AccessComplexity, Au:Authentication,
C:ConfidentialityImpact, I:IntegrityImpact, A:AvailabilityImpact

(3)注意事項

 深刻度が低くても、対策をしなくてよいということではありません。本ソフトウェアの利用者は必ず脆弱性対策を実施して下さい。

更新履歴

2007年8月20日 脆弱性の深刻度評価をCVSS v2へ移行
2007年3月28日 本脆弱性の深刻度を追記
2005年7月28日 掲載